RunMicroflowAsyncInQueue not working anymore

While rebuilding a part of our model I noticed during testing that this Java action is no longer working. The microflow is scheduled and the logs tell me that the microflow is executed, however the breakpoint is never triggered and looking at the data the microflow did not run. Debugging from eclipse does not help. I see that the java action fires the microflow. From a Java standpoint everything looks ok. Changing the RunMicroflowAsyncInQueue to executeMicroflowInBackground did not help. It is also not executed in the background. The executeMicroflowAsUser did work as expected. Trying to reproduce it in a test environment did not help. In the testenvironment everything works as expected. I double checked the userlib library for double entries and could not find anything wrong there. Anybody a clue why this might not work anymore, or what I could do to debug this further? Regards, Ronald [EDIT] Bump up to see if somebody has a suggestion before I am gone file a support request.
3 answers

I use this a lot in my apps in both 6.7.1 and 6.8.0 without any problems.

Have you tried re-downloading the Community Commons module?

Maybe a 'Clean deployment directory'?


We are currently running into the same problem. How did you manage to solve the issue?


Same problem today on acceptance and production of the same app. The servers were running for a couple of weeks without problem and suddenly the async flow were not being executed anymore. It started on two different dates.

Running on Mendix cloud V3, using Mendix 7.23.8 and communitycommons v8.1.0.

The last sign of life of the async call is the debug log message:

DEBUG - CommunityCommons: [RunMicroflowAsyncInQueue] Scheduling task #20

A restart of the server fixed it for now, but it is a problem waiting to return. Reproducing this will be hard i assume.

Does anyone have any suggestions?