Remove namespace xmlns:xml from operation in soap call

Hi there, Today I am trying to connect to a third party using a consumed soap webservice. They have some issues concerning an unused name space which is created by Mendix. They state that the xml namespace is a reserved namespace. Below you see a part of the created soap including the created name space. <?xml version='1.0' encoding='UTF-8'?> <S:Envelope xmlns:S=""> <S:Body> <ns2:SubmitJob xmlns:S="" xmlns:ns2="" xmlns:xml=""> </ns2:SubmitJob> </S:Body> </S:Envelope> I wonder: is it possible to remove this namespace? Kind regards, Wouter.
2 answers

By unchecking the "Send binary data as attachment (MTOM) option in the "advanced settings" of the consumed web service (see below for an example) the tag should be omitted and as result this should resolve the issue described here.




Hi, I currently have a project in version 5.21.4 and experience the same issue. I am consuming a third party webservice and mendix is adding --xmlns:xml=""-- to the outgoing webservice call. Funny thing is that in the modeler logging this extra namespace declaration is not visible, but when capturing the message with wireshark, it is.

The third party is returning an syntax error due to this extra namespace. So I was wondering if I can prevent mendix from adding it, or tell the third party that their WSDL is incorrect. Maybe somebody can point me in the right direction?

The used WSDL can be found here:

Please note that there is also an 'AnyAttribute' used. Mendix already states that it is not supported during WSDL import but apart from that it seems to be working normally.