Upgrade From to 5.11 - Strange Error

Hi All, We are trying to upgrade our mendix application from Mendix to Mendix 5.11. However as suggested in upgrade guide, I have upgraded my application to 4.8.9(latest 4.X) first and then tried to convert it to 5.11. I get some usual Java Action errors which I have solved completely. Now when I press next it says "An Error Occurred while running the migration. Press 'Next' to try again". No error is displayed. Just the above message appears. Pressing Next doesn't help either. It is so strange. If it doesn't show me any error and only a vague statement how do we solve it? Very STRANGE. There are no logs whatsoever, or may be I do not know where to look for them. Can anyone atleast point me where can i refer for logs, since I can't find anything online. Can anyone help me in finding the solution to this problem? Or at least point me to a right direction so that I can work on it? NOTE: Eclipse doesn't show any error in the project. Many Thanks, Sharad
1 answers


Go through your userlib directory and remove all the duplicate jar files. Most of the time that will solve your problem. Check if you do not have widgets like the formloader in your Mx4 model. Replace those for snippets. If all that does not help delete one library at a time untill it does work (bit tidious, but currently the only option that I know of).