Missing Icons - Reference Selector

I have an application (in 2.5) that is unable to display reference selectors, instead they are replaced with an error message such as "Unable to render mendixwidgetMxReferenceSelector_0 widget." I also get the following errors in the console window: 404 - file not found for file ui/images/icons/icnNew.gif 404 - file not found for file ui/images/icons/icnDelete.gif 404 - file not found file: mxclinetsystem/mendix/widget/styles/images/MxDataGridNG/prevpage.gif 404 - file not found file: mxclinetsystem/mendix/widget/styles/images/MxDataGridNG/nextpage.gif 404 - file not found for file ui/images/icons/icnReferenceSelector.gif Can anyone help with this?
2 answers

Hi James

Is this with production security settings? I have seen the first error ("Unable to render mendixwidgetMxReferenceSelector_0 widget) when the user does not have the correct permissions.

The 404 errors are exactly what they say - the icon does not exist in your application. I think those icon names are from the evaluation version of Mendix, and in 2.5 beta some of the icon names have been changed. You may be able to find the icons in the evaluation version install (like C:\Program Files\Mendix\2.4.5 Evaluation\web\ui\images\icons). If so, open the Images list in one of your application modules and use the Add button to import the missing icons to your current application.


Hi David, thanks for the reply, no this was in development, I say was because today when I redeployed the application everything worked fine. Curious, still provided it doesn't happen again, problem solved.