Gulp partly working.

I've probably used gulp in 6 other projects and the install and use of it never was a problem. I'm running Mendix 7.02. As you can see in the pictures, the installation was a few warning, gulp recognizes changes and the browerser:3000 is launced. However, when i change files, the CSS and sass files are not generated. I've tried to use gulp on another machine with the same project but the results are the same. What is the problem or how can I debug to find the problem? The only strange thing that I noticed is that there is no lib folder created under theme/styles/sass    
3 answers

Hi Pieter,

It seems that there is no lib-file created in your project. A work around may be to create a project in 6.8.1 (or earlier) and copy the lib folder to the sass folder in your own project (Projectfolder > theme >styles > sass).

Good luck!




Hi Pieter,

The warnings are totally normal, so you can ignore this.

Can you tell me how you have structured your project theme?

In your project you should have:

  • theme
    • styles
      • css
        • custom
          • custom.css
        • lib
          • lib.css
      • sass
        • custom
          • [folders with _xxxxxx.scss files]
          • custom.scss


That is the setup I have and how I structured ux-theming when we created this. In the top of your Gulpfile.js it will say what folders it will monitor (sourceStyleFolder). 

If I am correct, it will only pickup on changes in files that are already there. So if you create a new file, you will have to restart gulp. 

If it doesn't work, please file an issue on my Github repository. Please tell me which node version (type `node -v` in your terminal) and gulp version (gulp -v) you are using. I'll see if I can reproduce this issue.


Hi Jelte,

Thanks for your answer. The folder tree is exactly the same as in my tree, but that is the wrong one. I filled an issue yesterday which has been solved today. the lib folder should be created automatically under the sass folder when creating a new app.