REST SSL handshake fail

I just set up a new Mendix app environment, and it is my first time. I deployed a project that we have running in a separate Mendix app environment, and everything seems to be working as I would expect, except that when I try to connect to the REST services in the project via SoapUI, I get an error: Mon Jul 03 16:59:58 CEST Connection has been shutdown: Received fatal alert: handshake_failure This environment has the default Mendix SSL certificate installed, but so did the previous environment, and it worked there. Is there something else in this environment or in my project that I should be checking? This is the first time I'm setting up an environment from scratch, so any help would be very welcome. Thanks!
1 answers

Nevermind, the issue was that SoapUI is using an old JRE which has an old certificate store, and the certificate on the Cloud v4 environment was not recognized by it. Solved by changing the name of the JRE folder that SoapUI comes with and installing a 32-bin JRE 8 on my computer. Works like a charm now.