Issue with BootstrapMultiSelect widget and Windows Service Console

I have downloaded this new widget from the AppStore and relaced the checkbox set selector widget with it as it is better usage of screen real estate for large lists. The new widget works fine locally, but when I update my on-premise system it does not work. I have tried the normal things like clearing browser cache, but I just get a blank page with the lkoading spinner when trying to open a page containing the widget. The browser console shows the following: The text is mendix.sys.Data.get: error in handler for [76279718688587913] : BootstrapMultiSelectForMendix_widget_BootstrapMultiSelect_0.applyContext: Error: BootstrapMultiSelectForMendix_widget_BootstrapMultiSelect_0.applyContext: TypeError: this._$combo.multiselect is not a function _8a/<(_8c=["mendix.sys.Data.get: err...lect is not a function "])mxui.js...6771839 (line 29) .cache["mendix/logger"]//<.error(str="mendix.sys.Data.get: err...lect is not a function ")mxui.js...6771839 (line 29) Data/_13ab(_13ac=function(obj), _13ad=undefined, args=[76279718688587913 { id="mendix.lib.MxObject(Staf...mber:76279718688587913)", _changeData={...}, metaData=_122, more...}, Object { count=1}], _13ae=".get: error in handler for [76279718688587913]")mxui.js...6771839 (line 29) Data/this.get(_140b=Object { guid="76279718688587913", filter={...}, callback=function(), more...}, _140c=undefined)mxui.js...6771839 (line 29) .cache["mendix/lib/DirectObjectSource"]/788=58 { ident=58, id=58, trackId="76279718688587913", more...}, _789=function())mxui.js...6771839 (line 29) .cache["mxui/widget"]/28.collect(_47=[function(cb)], _48=function(), _49=undefined)mxui.js...6771839 (line 29) ... Does anyone know what might be causing this? Update 23 Sept I have updated all of the widgets that have new versions in the App Store, but the issue with this widget still persists. So, I installed the Mendix Service Console locally and set up the application there. I get the same issue. So the situation now is that I have the BootstrapMultiSelect widget running through the Modeler working correctly, but it does not work for the same application when run through the Windows Service Console - both on the same machine. Is there anything else to check? Update 24 Sept I have not been able to add the breakpoints as suggested - I assume I would need to run the project in eclipse to do this, and it runs OK locally anyway. However, I set up a small test project with just the BootstrapMultiSelect widget in it, and it worked properly both through the modeler and through the Windows Service Console. However, when I add a second widget (Calendar widget) I get the same issue - it runs OK from the modeler, but does not work through the Windows Service Console. I chose the Calendar widget as it also uses jquery. Does this help narrow down the issue? Update 25 Sept Issue fixed with new release of the widget
2 answers

I managed to reproduce this and it looks like it was being caused by the multi select plug-in being initialised with a different instance of jQuery than the one being passed into the widget.

I've copied an approach that Robert recently applied to the tooltip widget to address this. The changes have been committed back up to github and I have created release 1.3 which can be downloaded here:

If this resolves things for you I'll also publish a new version to the app store.


Are you using any other widgets in your project? Could be that one of these widgets does not include their jQuery correctly, which could mess with the bootstrap multi select. I can't see any obvious issues with the multi select just from checking the code on github.