CKE editor widget in Mendix appstore

Why does my CKE editor automatically add a paragraph element around any images inserted into my html? And even if i remove it manually it automatically set the paragraph again?
2 answers

Because it's the default in CKEditor configuration.

Apparently setting the config property config.entermode to enter_br would fix this accoring to

However, the CKEditor documentation states that this setting is not recommended.!/api/CKEDITOR.config

Please file a feature here in order to have this as a configurable option:

config.enterMode = CKEDITOR.ENTER_BR // pressing the ENTER KEY input <br/>
config.shiftEnterMode = CKEDITOR.ENTER_P; //pressing the SHIFT + ENTER KEYS input <p>
config.autoParagraph = false; // stops automatic insertion of <p> on focus

Adding these to the config.js file in the widget fixes the issue