Commit failed

Hi, Could someone please help me Committing my changes, please? I created new branch line and merged some changes in my new branch line without any errors/conflicts. I ran application locally and everything worked fine. but when I tried to commit my changes I got below error message: SharpSvn.SvnWorkingCopyLockException: Working copy 'C:\Users\Ikaur\Documents\WOM Backup\WorkOrderManagement-WOM_Merge_Sprint28AndSprint29' locked. ---> SharpSvn.SvnWorkingCopyLockException: 'C:\Users\Ikaur\Documents\WOM Backup\WorkOrderManagement-WOM_Merge_Sprint28AndSprint29' is already locked.    --- End of inner exception stack trace ---    at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, SvnException error, Object targets)    at SharpSvn.SvnClient.InternalSetProperty(String target, String propertyName, svn_string_t* value, SvnSetPropertyArgs args, AprPool pool) I installed Tortoise SVN 1.9.7. I tried following: Right clicked on the Parent folder > SVN Upgrade Working Copy Right Clicked on Parent folder again>Tortoise SVN> Clean UP but after doing this I saw red escalation mark on my MPR file then I tried right click again on the parent folder > SVN Commit after doing the 4th step I am seeing below issue.    
4 answers

After doing the svn repo update to 1.9.x it won't be possible to sync that repo with Mendix Team server again.

You can usually solve something like this by:

  • rename the folder where your working branch is saved
  • download the branch again fresh from team server
  • copy the changed project file and other changed files into the fresh download (DO NOT COPY ANY SVN FILES)
  • open the project in the modeler again and try to commit.

Have you seen this question? I would change your version of svn to 1.7


Once you get 1.7, I would try

  1. check for modifications ( You will be able to see if there are any conflicts and resolve them)
  2.  Then you can try release lock
  3. Then I would try committing from SVN

I had 1.7 yesterday with the same exact issues I already mentioned in the question above. I installed 1.9 today only to see if I can get rid off those errors. but nothing changed still stuck at the same errors with both versions.


Do you have any problems getting to the sprintr page from your browser?

Have you tried to use 'Resolved...' in SVN?