Problems with Publish

I'm trying to get started with the tutorial and am on the Publish step.  When I click Publish, it just says "Retrieving app environment status..." and never changes.  Anybody know what the problem is?  I have tried several times and waited 20 or 30 minutes and nothing ever happens.   Thanks!
4 answers

I have done the getting started training at Mendix HQ in Rotterdam a few weeks ago and completed this training. Experienced this problem also while doing the training. What I did to solve it was to work with the Chrome browser, because I experienced problems with other browsers. It still takes a long time, but will work eventually. Also they told me that there are some problems with the Web Modeler as it still in Beta, which means there are some bugs. It will sometimes still take a long time, but just refresh the browser and be patient. After you finish the get started course and begin on your rapid developer training you will work with the Mendix Desktop Modeler. Then you wont have this problem anymore.



I also have the same issue, but with my own app (basic app with 2 pages and 2 micro flows). Been waiting for more than 1 hour.

Have  tried the following but nothing works: 
- Log out and log in (also from different machine) 
- Deleted cache from browsers 
- Tried publishing the app from different browsers and OS (Safari, Chrome) 
- Killed the process by pressing the x


Hi ,

I did some tutorial and is facing the same issue. I have a Windows 10 machine, and a chrome browser. 

Also It is happening for all apps. One app which I had published before is showing - Retrieving app environment status...

but never completes.

can anybody give a solution.


Hi Mark,

Which tutorial are you following and which module/lecture?