Calendar Widget Update

After updating our calendar widget in the project, we updated all widgets and received no errors. The calendar will not render in the browser. We have cleared all history, and tried different browsers. Calendar Version 4.5 What can we try? The browser console says: "No constructor found for widget calendar.widget.calendar" The browser page displays: "No constructor found for widget calendar.widget.calendar" Thanks
5 answers

To resolve this issue, add the following to the end of calendar.js::

require(["calendar/widget/calendar"], function () {
    "use strict";

Also, you could create an issue at:


We have updated the Calendar widget to version 4.5.3, which includes the pull request of Ronald Catersels (thanks for that!). This will fix the no constructor found issue. AppStore version is already updated and approved.


Have you tried to completely remove the .mpk file first and then downlaoded the appstore version? What also could help is implement the cachebust solution: A cache bust is a unique string generated on every project deployment. To make use of cache busting you should modify your existing theme's html files. Add ?{{cachebust}} to every url pointing to a static resource (e.g. scripts and stylesheets). Additionally add a property with name cacheBust and value "{{cachebust}}" to the dojoConfig defined in the index page.


<script> dojoConfig = { baseUrl: "mxclientsystem/dojo/", cacheBust: "{{cachebust}}" }; </script> <script src="mxclientsystem/mxui/mxui.js?{{cachebust}}"></script>



Hard to say as the error can be a result of different causes. In order to resolve this we really need more context and the possibility to debug the problem. Can you provide a test project reflecting your setup by

  • Extend the test project on GitHub) or
  • File a ticket in our support portal

Jeff, did you eventually solved this problem? Run into it myself. Tried everything (cleaning cache, checking userlib and cache burst is implemented). But still on every page of this widget the no contructor found error.