Mendix loading bar after migrating to Mx6

After upgrading our application to Mx6 (and resolving all the conflicts, warnings and java errors) I managed to run my app. However whenever the app is opened a 'Mendix loading bar' appears (just like during a running microflow). I don't get an error, I don't see anything in the console (both mendix modeler console aswell as firebug console). There are no widgets (or microflows) on the home page (I've tried several different landing pages, all with the same result) Any suggestions on where to start debugging?
2 answers

The problem seems similar to the behavior you might be seeing if you have outdated widgets (although the lack of logs in firebug is odd). The broken widget doesn't necessarily have to be on the home page as the client downloads all custom widgets on first access, regardless of where they're used in your application.

You could try running Tools > Check widgets from the modeler. If that also doesn't tell you what's wrong I'm afraid you're left with deleting custom widgets until your app runs.


Microflow label doesn't work in MX6 because it's not relevant anymore. In Mx5 a replacement has been introduced, you can use the action trigger (native modeler widget) instead.