Empty response object in webservice

Hi, I am currently working on a web service which has a simple response of four fields. =>I am able to call the web service and its not erroring out. =>I cant see anything in the logs =>I have checked with unix team they can confirm it's responding as expected with the xml. =>However when i debug it's returning an empty object. I have tried several things like creating it in microflow or searching for it so I can debug it further but as it returns empty object most of the debugging cant be done. I can debug on return value which just says object is empty. Any suggestions on why this might be the case? I have worked on several web services before but havent come across this strange issue. Any Kind of help would be appreciated. <?xml version="1.0"?> <xs:schema xmlns:xs="test.test.com" xmlns:lv="test.testttt.com//" xmlns="test.test.com///" targetNamespace="test.testtt.com" elementFormDefault="qualified"> <xs:element name="ClaimsTrackingrespond" type="lv:ClaimsTrackingrespond"/> <xs:complexType name="ClaimsTrackingrespond"> <xs:sequence> <xs:element ref="lv:SearchStatus" minOccurs="0" maxOccurs="1"/> <xs:element ref="lv:SearchStatusReasonCode" minOccurs="0" maxOccurs="1"/> <xs:element ref="lv:SearchStatusReasonDesc" minOccurs="0" maxOccurs="1"/> <xs:element name="MatchedVehicleDetails" type="xs:string" minOccurs="0" maxOccurs="1"/> </xs:sequence> </xs:complexType> <xs:element name="SearchStatus"> <xs:simpleType> <xs:restriction base="xs:string"> <xs:enumeration value="Success"/> <xs:enumeration value="Failure"/> </xs:restriction> </xs:simpleType> </xs:element> <xs:element name="SearchStatusReasonCode"> <xs:simpleType> <xs:restriction base="xs:string"> <xs:enumeration value="VehicleFound"/> <xs:enumeration value="ClaimNotOpen"/> <xs:enumeration value="ClaimNotFound"/> <xs:enumeration value="VehicleNotFound"/> <xs:enumeration value="Other"/> </xs:restriction> </xs:simpleType> </xs:element> <xs:element name="SearchStatusReasonDesc" type="xs:string" /> </xs:schema>
0 answers