Mendix version above 7.20 facing issues while connecting to teamserver.

Hi All, We are facing a strange issue, I am getting connection timeout from teamserver (Mendix.Modeler.VersionControl.VersionControlException: An error occurred while retrieving the branches. ---> SharpSvn.SvnException: Unable to connect to a repository at URL '' ---> SharpSvn.SvnException: Connection timed out). This started happening a week back for version 7.20 , I have 7.1.1 which is perfectly working. I am behind company firewall, so configured the proxy as well. I tried the option in and Is there any changes in network connectivity from version 7.20? Can somebody help me on this? Regards, Hari
3 answers

Yes, there is indeed a change in how we talk to the Team Server. Since Mendix 7.17, where we introduced the new sign-in screen in the Modeler, we communicate through a different HTTP library which causes issues for some users.

For this reason, we have written a troubleshoot guide for version control:

The time-out issue you are experiencing is also described there:

I hope this works for you!


Have you tried it a second time after the error comes up? 


URL has changed: