Unable to Upload file/image in Mendix 8 beta version

Hi All, I am trying to upload file/image in Mendix 8 beta version, while i try to select the file,the default browse option is not responding.Kindly check the below attachment.Can someone help me out on this.Thanks in advance!.
3 answers

Can’t reproduce this. Just tried it in V8 and works like a charm, at least without authotization, see https://mydemoversion8-sandbox.mxapps.io button Forum questions, button question 94169, both in normal page and popup.

Tried with security set to Demo/Prototype, also no problem,

Does this error also occur if you set security to none? Try recreating a new entity (spec from system.image)


Probably a bug, i encounter the same problem, security and inherited access rules are set accordingly.

A workaround for a small  file:

1) decode your file to base64

2) Create a variable with that decoded base64 (hardcoded, watch out for a Out of Memory error )

3) generate a file by using  base64tofile (communitycommons java action)


Did you create your own specialization of System.Image? You cannot use System.Image directly but have to create your own entity that is a specialization of System.Image.