Java Development Kit (JDK) was not found

I am not sure what changed on my machine recently but now when I click on Run Locally in the Desktop Mendix Modeler I get the error: Java Development Kit (JDK) was not found. Please check the JDK directory in the Preferences dialog (Edit > Preferences). I click on the Edit Preferences button and it opens to the Preferences.  My JDK directory currently reads “C:\Program Files\Java\jdk1.8.0_144”.  I click on Browse and it takes me to that directory (meaning the directory DOES exist.)  I choose it anyway and click OK and then OK again to close Preferences and it gives the same error again. I am on Windows 10.  I am not familiar enough with JDK to look in the folders to tell if it is all there or not.  I also am not sure how to install it, in case that is what I need to do. Since the folder does exist I thought it might be a permissions issue.  However; I ran Mendix Modeler by right-clicking and choose Run as Admin.  Still get same error.   This was working last week or so and I know of no changes to the system. Any ideas?
1 answers

I ended up installing JDK and it is working now.