Custom Date Not Working in Data Grid with export CSV

I am using custom date format for column for my export CSV in data grid. I want to format date as ‘’yyyy-MM-dd  HH:MM:SS’’ but after putting this, when I download CSV it gives me #### with Date format as ‘’9/17/2019  10:09:00 AM”. I tried with string attribute from microflow and formatting the date but still the same result. Please help. Thanks in advance.
2 answers

It probably works fine, downloads to CSV with the correct format, but you are probably inspecting the resulting downloaded CSV by opening the CSV with Excel. Excel formats the Date to “9/17/2019  10:09:00 AM”.

Try opening the CSV in notepad to check if the date is formatted correctly. Notepad does not apply a dateformat to the date-strings it finds.


Hello Kavya,

In addition to Tim’s answer, your format might also be referencing the wrong types within the date.

I believe that your minutes (09) are referencing Months. Formatting is case sensitive, for example MM = Month, while mm=Minutes.

Your format should probably be ’yyyy-MM-dd  HH:mm:ss’ if you encounter further issues with the actual data exported.

Hope this helps