Javascript Actions throws a compilation error

Hi. I’m trying to use a Javascript Action from a nanoflow, but when I run the project I get a compilation error. I believe it’s because I’m running Mendix on mac (via parallels).  Does anyone know where I can update Webpack settings for the configuration.output.path attribute to be absolute? I’ve tried searching for that term but can’t find it anywhere within the project directory or modeller. Error below… Invalid configuration object. Webpack has been initialised using a configuration object that does not match the API schema.  - configuration.output.path: The provided value "\\\\Mac\\Home\\Documents\\path\\to\\project" is not an absolute path!    -> The output directory as **absolute path** (required).    
1 answers

Hi Patrick,

I use Mendix on a Parallels VM also, and I sometimes run into scenarios like the one you’re mentioning. I also use the Parallels Folder Sharing option, so that I can open Mendix project from either the Mac side (\\Mac\home\...) or from some letter drive in windows (Y:\macShare\...) → Which letter depends on how you’ve setup the folder sharing in Parallels

For me, I need to make sure that I have the project open from the letter drive when I’m working with Javascript. This ensures that the path that the modeler looks at when it tries to webpack JS content is absolute. 

In other words, ensure that you open the Mendix project file (the .mpr) from the Windows file location, and try your build again.

I hope this helps!