Merge issues - Mx 7.23.11

Hi guys,   Our team is experiencing a lot of issues during merging of feature branches into mainline. Most common exception we are getting is:   SharpSvn.SvnDiffException: Unexpected end of svndiff input at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, SvnException error, Object targets) at SharpSvn.SvnClient.Merge[TRevisionRange](String targetPath, SvnTarget source, ICollection`1 mergeRange, SvnMergeArgs args) at Mendix.Modeler.VersionControl.SvnConnector.<>c__DisplayClass67_0.<Merge>b__0(ISvnClient c) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 872 at Mendix.Modeler.VersionControl.SvnConnector.PathClientDo(String workingCopyPath, Action`1 action) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 903 at Mendix.Modeler.VersionControl.RevMerger.SvnMerge(RevMergeState state, IProgressInfo info) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core.View\VersionControl\RevMerger.cs:line 353   No real scenario when/why this happens. For example, if you create feature branch from revision 400 of mainline, and in your feature branch introduce some changes, commit them, forcing the feature branch to be one version above the mainline, and once you try to merge your feature branch to mainline, this error occurs.    I’ve tried multiple things, from reinstalling the modeler, SVN, working with and without SVN, it behaves the same with all tried “fixes”, meaning, it behaves unpredictably and you never know when you will successfully be able to merge.   Sometimes, it works without issues. Other team members are getting this error more often the other ones (though we all were using the same version of modeler, SVN version as suggested on Mendix team server guide etc).   Has anyone experienced these issues? Any suggestions for a solution, workaround?
1 answers

Did you already contact Mendix support? This sounds like an issue on their side.