Errors using AWS DynamoDB connector

I am trying to connect to AWS DynamoDB with the session credentials and facing errors trying to get/use credentials; With the updated AWS Authentication connector, after setting the IAM role, profile configuration in AWS and the Profile configuration constants, I am able to fetch the credentials successfully. However, when I use the AWS DynamoDB connector, I am seeing errors on the micro flows within the dynamodb connector(screenshots attached).  a. The parameters [AWSAuthentication.GetStaticCredentials] - are these parameters in dynamodb -> GetCredentials microflow -> java actions 'GetStaticCredentials' still valid with the latest updates to AWS Authentication connector? Note: I have included communitycommons module from marketplace. similar issue for AWS S3 connector as well.   b. Can we use the credentials from the authentication connector using temporary/static microflows instead of dynamo db GetCredentials microflow? Are there best practices on the credentials usage in the app, when trying to fetch different resources      
2 answers

Hi Aravind,

thanks for reaching out!


Please make sure to use the latest versions of both AWS Authentication Connector and DynamoDB Connector. To do so, on the Marketplace, navigate to 'Releases' and make sure to download the versions with the highest release version number. For DynamoDB Connector this is 2.0.0 at the moment. 


There is a misleading behavior of the Marketplace at the moment, where clicking the Download-button will import the version with the most recent release date, not the one with the highest version number. 

In case of the DynamoDB, the latest release is a fix version of an older major version (1.0.3), so this one is being pulled automatically, which causes errors because it is not compatible with the Authentication Connector 3.0 version.


Updating DynamoDB Connector (and other AWS Connectors you are using) to the highest release version in combination with the highest release version of Authentication Connector should solve the issue. 


Let me know if this worked for you or if you need any further help!


This worked!  A fix for the marketplace issue here is now also in the backlog.  Thanks for posting here and glad it worked Aravind!