Data Hubs OData Connector: On update broken SQL statement?

Mendix Studio Pro 9.8.1   Hello, see also (BTW: Is there a better/correct way to link other questions?). I tried to use update on Mendix OData service but that fails horrible. For some reason a -- IMHO -- wrong SQL statement is generated although a remote OData service shall be called. (Well, maybe it's some kind of "caching" table.) The table contains only two columns with two ID fields. But not the referenced column. The generated SQL statement contains the target column in the "SET" part... Does anyone experience the same issue? Or has it working properly? Or any idea what I do wrong here? Caused by: java.sql.SQLSyntaxErrorException: user lacks privilege or object not found: hartl in statement [UPDATE "myfirstmodule$gerhards$pk"  SET "some_column" = ?  WHERE "id" = ?] Thanks, Dietmar    
1 answers

Hello Dietmar


How are you trying to update? If you haven’t tried below option, please give it a try.

On the Save/Update button call Microflow and add only one activity (Send external object) and pass the object being updated. I could use this without any issue.