Cannot access Team Server URL (git)

My team recently migrated our app from SVN to Git and since then I am not able to access our team server via the URL provided in the developer portal. I created a personal access token (pat) and gave it the following scope:  mx:modelrepository:repo:read   I have also tried full read and write access for a different token’s scope. When I navigate to my team server’s git URL I am prompted for username and password. I enter my access token as the password and receive the message  You're not allowed to perform this request. I am assigned to the scrum master role in the developer portal and have all permissions for our environments. I have also asked our technical contact to create a pat and she gets the same above message as I do. Is there anything I’m missing or a reason that we can’t access our URL? Thanks in advance! 
1 answers

What you tried should work in terms of using the token as the password. Are you using your Mendix e-mail address as the username, too?