User comes back as Anonymous after SSO login

1
Hello Every one,   We are using OIDC module for SSO login (PingOne), after entering credentials and validated, OIDC.webcallback Rest call got invoked and session was created for the user using java action, I can see logs for that,  after that from PingOne flow was redirected to application, after redirect current user was shown as Anonymous, so it again goes to SSO login flow, since the user session was already created at PingOne, it does not prompt for password, it redirects flow application.   This process kind of goes in loop. every time session created for user in mendix but during call back it shown as Anonymous.   This approach works well in local after login I can see home screen, but in Test region I'm the above facing issue.   I tried with multiple user logins, all has same issue.   Thanks & Regards, Balaji S    
asked
1 answers
2

Hi Balaji,

 

What version of the OIDC SSO module are you using?

 

I'm asking this because I had exactly same problem, and my solution was to upgrade the OIDC SSO module. (In my case I had Mendix Pro 9.20 and I had to upgrade the OIDC SSO module from v1.0.1 to v2.0.0, as stated by the documentation. This is because there were some changes in the cookies handling as seen on the second screenshot):

image.png

 

However, I see that you are using Studio Pro 9.16, so in your case I suggest first trying the OIDC SSO v1.1.1, and if that doesn't work try OIDC SSO v.2.0.0:

OIDC SSO Marketplace

image.png

 

PD: whenever you upgrade a module, also make sure to go to the userlib folder and remove any duplicated libraries.

 

I hope that solves your problem, if it does, please mark the question as solved, best regards!

answered