Java Dependency Error: Could not resolve the CycloneDX Gradle Plugin while installing Community Commons, Excel Importer, Excel Exporter from Mendix Marketplace

0
Getting below error after downloading Community Commons, Excel Importer and Excel Exporter from the Marketplace.   FAILURE: Build failed with an exception. * Where:Build file 'C:\Users\user\Mendix\Stock Management-main\vendorlib\temp\build.gradle' line: 2 * What went wrong:Plugin [id: 'org.cyclonedx.bom', version: '1.8.1'] was not found in any of the following sources: - Gradle Core Plugins (plugin is not in 'org.gradle' namespace)- Plugin Repositories (could not resolve plugin artifact 'org.cyclonedx.bom:org.cyclonedx.bom.gradle.plugin:1.8.1')  Searched in the following repositories:    Gradle Central Plugin Repository * Try:> Run with --stacktrace option to get the stack trace.> Run with --info or --debug option to get more log output.> Run with --scan to get full insights.> Get more help at https://help.gradle.org. BUILD FAILED in 7s  
asked
2 answers
0

Hi Ardra,

 

A lot of colleagues in my organization had this same problem before. In our case we found out that it was because ZScaler was blocking the connection to Gradle repositories. We had to add the root certificate of ZScaler into the installed Java keystore to allow Studio Pro to connect to such repositories.

 

If you use something similar to ZScaler that may be the problem, you follow this steps to add the root certificate into the Java Keystore (you need to obtain your own root certificate file from your organization if it applies):

 

1) Install KeyStore Explorer:

https://github.com/kaikramer/keystore-explorer/releases/

 

2) Figure out where Java JDK was installed for Studio Pro 10:

step2.jpg

 

3) Go to the JDK directory > lib > security, and make a backup of the cacerts file somewhere else:

step3.jpg

 

4) Open the Keystore Explorer app:

step4.jpg

 

5) Drag the original cacerts file from the JDK directory > lib > security path into the KeyStore app (if you need admin rights, make a copy of the cacerts somewhere else and modify it there):

step5.jpg

 

6) Enter the prompted password, default password is changeit

step6.jpg

 

7) Drag your Root Certificate file into the list of certificates of cacerts:

step7.png

 

8) Click Import, leave default alias as it is and click OK both times:

step8.png

 

9) Save changes (and if needed, replace the original cacerts file with the modified one): 

step9.png

 

10) Restart computer

 

11) Go back into Studio Pro and check if the error is gone

 

 

I hope that helps you solve your problem, best regards!

answered
0

Or if you have in house gradle repository then you can mention the location of the repository in Preference option of Studio Pro. See https://docs.mendix.com/refguide/preferences-dialog/#333-repositories

answered