Datahub Odata GET request

Hey there, I have a 1-* association, with 1 being a Datahub entity (Zaak), and * being a local entity. In Mendix 8.15.2, I was able to retrieve the datahub object over association, This resulted in the following OdataConsume query in my console:  Response content for GET request to$filter=%28ID%20eq%206473%39244643451186L%29 HTTP/1.1 200 OK Now I've upgraded my project to Mendix 8.17, and when trying to execute the same logic, the Odataconsume query is as follows: Response content for GET request to$select=ID%2C%5Aaakidentificatie%2COmschrijving%2C%5AaakTypeCode%2CStartdatum%2CEinddatum%2CBsn%2CResultaatomschrijving%2CStatus%2FID%2C%5AaakType%2FID&$filter=%28ID%20eq%206473%39244643451184L%29&$expand=Status%2C%5AaakType HTTP/1.1 400 Bad Request In both cases the datahub object is actually associated to the local object, and the list of datahub objects also shows up in the reference selector. I am able to select a new reference, but when I try to execute the retrieve over association logic afterwards, it results in the error. Directly retrieving all the Datahub object from database was also possible in 8.15.2, but now also results in a system error. Securitywise the two versions are set up the same. I can see there's a difference in how the query's are written, but I think this is mentioned in 8.17's release notes. Update: Problem solved. The publishing application was still at version 8.15.2. Upgrading to 8.17 solved the problem.
1 answers

Hi, we’re also experiencing Datahub issues after upgrading from 8.15 to 8.17. For us, the issue was that we had an entity with an attribute and a association with the same name. The publishing app is automatically renaming the association by adding “_2”. In 8.17 this results in errors. 

In your case I would suggest upgrading the publishing app as well. Mendix has optimized the Datahub by allowing to only retrieve required attributes, were this would always be a complete object in previous Mendix versions. It could be possible that the publishing app cannot handle this. 

It looks like Mendix had made some improvements/optimizations but not everything was tested well enough...