MQTT Connector: Cannot find microflow for message received on topic $topic

MQTT Subscribe action is causing a strange error I subscribe AWS Device Shadow MQTT topics as described here. A microflow is specified as OnMessage microflow. All parameters required for subscribe are set correctly.  But when the app is run and subscribe is called, the onMessage microflow is not triggered instead this error message appears in Mendix console Cannot find microflow for message received on topic $aws/things/thingname/shadow/get/accepted I am trying to get device shadow using MQTT connector. For this an empty message is published to $aws/things/thingname/shadow/get topic and it should send response to the /get/accepted topic mentioned above The above scenario occurs when qos level is set to 0 for the publish action. If it is set to the highest 2 (exactly_once_2), then publish does not work and error appears in console that connection is lost. After that connector makes 10 attempts to reconnect. All errors in Mendix console appear with log node ‘MqttConnector’. I have checked source code of the connector and these errors are mentioned there. What I understand till now is that the problem is with source code of MqttConnector and somehow connection is lost when working with shadow topics.  I was able to subscribe to other topics, also updating shadow with desired properties worked. Get/read shadow is not working.  Tried it in Mendix 9.2.0, 8.18.1 and 8.0.0 Note: I have tested the working of get shadow using shadow topics directly in AWS console and using MQTT Box app from Windows Store. It worked. So the cloud side is correctly configured and working. Something is wrong here in Mendix or the connector. Anyone having any suggestions/ideas on this issue? Any leads? Thanks in advance
0 answers