SAP OData: Connection Timeout (only on Mendix Cloud)

Hi, I am consuming an OData Service from an SAP System of a customer. When configured everything on my local machine, the connection works smoothly and I receive the dataset form SAP via OData. However, after deploying to the Mendix Cloud I am always receiving a connection timeout message. I also tried to set the timeout of RequestParams higher then the default 60 seconds, but it didn’t help.  What I think could be causing the problem is that I need to be in the corporate-network/VPN to get access. I tried to access the SAP Endpoint via Postman without being connected to the VPN (on my localmachine) and it throw an timeout error. While being connected to the VPN everything works.  Do I have to configure something on the Mendix App (on Mendix Cloud) so it connects throw the coprorate-network/VPN? The interesting part is that the customer has another app with another SAP Endpoint which works totally fine (and I just have to run VPN on my local machine), but has nothing special configured which could make it different then my app. Best regards, Ömer
0 answers