Mendix PWA - Log in with SAML2.0 module is valid, yet app gets stuck on white screen

We built a Mendix application with PWA Web profile: the application has a desktop-view and a mobile-view. Whenever we log in the application on a phone, the log in is validated, the SAML logs in the app are checked and the Active Directory logs a correct log in for this user, yet, the app shows a white screen constantly. Even for more then 10 minutes. There are no errors in the front-end or on middleware-level. On the desktop, this issue never occured. When the end-user minimalizes the app and re-open it back again: the end-user sees that he’s logged in and the app is working fine. I do however do not want the blank/white screen for a first log in attempt. Has anyone else experienced this behavior? Should we turn to OpenID Connect? All feedback is usefull! Thank you! Kind regards, Leander   Edit: after iOS debugging, we noticed that the manifest file kept “hanging” in the network tab. Yet, when we manually enter the URL, we can clearly see that the webmanifest does exist.
2 answers

Hi Leander,

I have some experience with PWA / SAML combination, have you tried setting a static start_url in ‘manifest-overrides.webmanifest’?

Your issue does not sound like mine, but the problem i had was that the loaded page (index3.html) was installed and this causes the app to skip the SAML authentication. My webmanifest override looked like this to get SAML to work:


  "short_name": "---",
  "name": "---", 
  "background_color": "#FFFFFF",
  "display": "standalone",
  "theme_color": "#222B53",
  "start_url" : "./index.html"



After analysis by ourselves and Mendix support, the issue persisted and is due to Apple web-kit. We then tried with OIDC and since then, the issue no longer persisted.