Email connector - The string provided is not an empty string

Dear all, I tried to install the email connector, because – unfortunately – the Email with templates module is no longer recommended (although I loved it). The Email connector however seems to be far from ready and usable if you allow this comment (seeing the numerous threads here in the forum). I get the same error message that all the others get: Frontend: smtp (whatever that means, completely useless feedback) Backend: The string provided is not an encrypted string. Returning the plain string. Here is what I have already done / tried: followed the manual very precisely as laid out here: Email Connector | Mendix Documentation created a brand new app (that consumes cloud and hdd space by the way) and copied over the userlib as advised here:  updated everything once the app is up and running in MxModelReflection provided an alphanumeric 16 digit passphrase / key for the EncryptionKey constant (completely randomized, meaning I did not use any clear names or words) chose {AES3} for the EncryptionPrefix My situation is this: to properly test emails and develop some templates I need to use a local mail server application like Mailhog that provides an SMTP server at (I of course separated IP and port when entering into the config). It is not acceptable to go through any public services like Gmail etc because once I start creating templates even the structure of how my emails look like would already be a competitive advantage (and also, I don’t want to mix private accounts with business topics). Hence I must test locally, but for the app initially at least I also tried GMail which led exactly to the same error. Any advice on this problem that seems to originate in the Encryption module somehow (maybe I’m mistaken) would be highly appreciated.  
3 answers

Hi Philipp,


thank you for taking the time to provide a comprehensive feedback. After a first glance, the issue might be caused by providing an encryption key with a length of 16 characters. The encryption module requires a key with 32 characters. (


I have taken a note and will inform the team to see if we can improve the user experience to avoid this situation in the future.


Best regards




Facing this same issue, I'm using this Email connector as a fresh module (No other Email modules in the Project), it's working fine in local environment but in the cloud the issue happening.


Any solutions or any other allternative solution could you please asset on this.

Thanks in Advance.


Hello Philipp,

Hope you are using the latest version of the email connector, requesting more information on the issues you have mentioned.

  • Can you please check your userLib folder again and remove any other email module jars if available? 
  • Backend warning you mentioned is not related to the issue you described.
  • Ideally you should be able to use local mailserver like papercut or mailhog for your testing, as many users are already doing the same, please refer documentation
  • Can you please share the steps how are you trying to use the email connector, I mean using the UI or creating the email account object using your own Microflow
  • Also enable debugging and share debug logs if possible