Error while running local app in eclipse

Dear Mendix community. I am facing issue in running my local app using Eclipse.   I am using Mendix studio version 9.24.6 recently migrated. I updated the Database Connector module from Marketplace.  I did clean deployment folder and sync with project directory. After that I did deploy to eclipse. When I run the local app from Studio pro , it works fine. When run from eclipse, it shows below message.   java.lang.Error: Unresolved compilation problem:      at saml20.implementation.common.SAMLUtil.getActiveSSOConfig(    at saml20.implementation.SAMLRequestHandler.initServlet(    at saml20.implementation.SAMLRequestHandler.<init>(   Java Version used in both Studio pro and eclipse: jdk-   I have not created/modified any java files in older versions of Mendix studio pro as there were no requirements. so not sure it is the Studio pro issue or data base connector module issue.     Things I tried to solve the issue: 1. After cleaning deployment folder and deploy to eclipse, I did clean and build in eclipse before start the app in eclipse. 2. I added same Java version to project and workspace build path 3. Removed jars with different versions and kept only latest versions of all jars.   Now I am trying to run in eclipse is that I want to add a line dataSource.setKeepaliveTime(30000); in a java file : When I add this line studo pro also throwing compilation error.  javasource\databaseconnector\impl\ error: cannot find symbol    [javac]         dataSource.setKeepaliveTime(30000);    [javac]                   ^    [javac]   symbol:   method setKeepaliveTime(int)    [javac]   location: variable dataSource of type HikariDataSource    [javac] Note: Some input files use or override a deprecated API.    [javac] Note: Recompile with -Xlint:deprecation for details.   Has any one face the issue before? Please let me know how to solve the issue. Please help.   Many thanks in advance, Nirmal  
1 answers

Hi Nirmal,


Did you try and delete the entire project from eclipse (do not select delete contents from disk) -> redeploy for eclipse from studio pro then open it in eclipse?

Sometimes eclipse just does not synchronize and this remediates it.

Let me know if this works.