Unable to initialize the Servlet configuration when trying to configure the SAML_SSO module

Hi, I implememented the SAML_SSO module. When I start the application I get the following error:   java.lang.NullPointerException: null     at saml20.implementation.common.Constants.getSP_URI(Constants.java:175)     at saml20.implementation.common.SAMLUtil.getMetadataConfig(SAMLUtil.java:334)     at saml20.implementation.SAMLRequestHandler.initServlet(SAMLRequestHandler.java:76)     at saml20.implementation.SAMLRequestHandler.<init>(SAMLRequestHandler.java:63)     at saml20.implementation.SAMLRequestHandler.getInstance(SAMLRequestHandler.java:55)     at saml20.implementation.SSOServerConfiguration.start(SSOServerConfiguration.java:18)     at saml20.actions.StartSSO.executeAction(StartSSO.java:27)     at saml20.actions.StartSSO.executeAction(StartSSO.java:16)   I Can't find a constant named: "getSP_URI" We configured the Startup flow in the configuration of the application. We tried version 1.7 and v1.6.1 It is an on premise installation on a Windows server. Thanks for your help.  
2 answers

Hi Cillus, 


getSP_URI isn't a Mendix constant but a Java function in saml20.implementation.common.Constants.getSP_URI:


public final String getSP_URI() {
        if ( this.SP_CONSUMER_URI == null ) {
            this.SP_CONSUMER_URI = Core.getConfiguration().getApplicationRootUrl();

            if ( !this.SP_CONSUMER_URI.endsWith("/") )
                this.SP_CONSUMER_URI += "/";

        return this.SP_CONSUMER_URI;


It seems like the ApplicationRootURL is missing in the configuration in the Mendix Service Console under configuration. It is called Public application root URL



I'm getting  the same error when running locally in the modeler. Using version 1.9.2 of the saml widget.

What needs to be changed?