connection error

Hello, We are seeing the sessions are not getting logged off even after 2-3 days of inactivity and the logs contain the below message. We are also intermittently seeing connection errors while accessing the application. Can anyone help me find the root cause for these issues. WARNING - Core: Failed to remove session 'd28caf83-bf4d-44e2-8827-194d7b9b8b2d' for user because actions are still running for this session. Client access has been disabled. Session will be attempted to be removed again in 150 seconds. We have tried setting the ClientQueryTimeout and increasing the ConnectionPoolingMaxActive but still getting the same error. Thanks in advance!  
4 answers

I would advise you to update to 6.9.1. See the release notes here:

Version 6.9.0 has a bug that has been fixed in 6.9.1.





You may check "Running Actions" for the running actions, maybe this gives you an insight in why the session is not destroyed. It could be a database lock.


Thanks for the response. I checked running actions and found that sessions are not getting destroyed as it is still trying to retrieve UserRole by $currentUser/UserRoles. The console shows the duration of this retrieve action as more than 2 hours and the associated user is no longer logged into the application. Our automation scripts use the same user ID to test the application on multiple machines/browsers. Does this has anything to do with the lock on UserRole entity? If so, how can we fix this issue?


UPDATE - We tried testing the application manually with different user IDs and still the sessions are not getting destroyed trying to retrieve UserRole by $currentUser/UserRoles.