Mendix Service Call Issue

Hey guys, I made a service in Mendix to expose some product data to another Mendix application. I’ve never really had an issue with the service until today when all of the sudden I received this guy→ SyntaxError: Unexpected end of JSON input. I know this error usually stems from XML coming back from the service and you trying to receive it in JSON format, however, I export the product data using a JSON export mapping and package it up into an HTTP Response to send it on it’s way to the other app.  Here is the other thing, the service works fine in Postman, works fine in Swagger UI, even works locally, but always fails when I move into the deployed version of the app with the same error.   Any tips/help would be much appreciated! ***Update: I made no changes to the logic, environments, or data and after 30 minutes of the application just sitting there in an open session my microflow (And service call) worked fine with no errors or issues. I’m still not comfortable with this outcome, and would love some input/thoughts about something I can do to make this more full-proof. Thanks in advance! 
1 answers

Could this be a data related issue in which a call to the service will deliver a json that is not fully compliant.

Maybe have some illegal character in a string. In postman this will probably not lead to an error when looking a the raw response, but would lead to an error in the Mendix environment. 

See for a list of “illegal” characters RFC 7159: