Proxy Configuration Not Available in Call Web Service

Hello everybody, I tried to call a Web Service using the SAP Cloud Connector by using a configured (and working) Destination on the SAP Cloud Platform. As I understood it I have to configure a Proxy in the “Call Web Service”-Action. But I am not able to do that because it is grayed out:   I also checked the Project Settings and I have enabled the optimized Web Service calls – What seems to be a prerequisite to change the proxy configuration. I also checked other Mendix-Versions (E.g. 7.20) and it worked there. Is this some kind of Bug in Mendix 8?
2 answers

Hello Florian

this feature is working in an older Mendix version? Have you tried it with the newest Mendix 7 version (currently 7.23.11)? Have you searched for the issue?

Maybe you’ve found a bug on Mendix 8. If you think so, you could create a ticket on and provide a sample project with the issue.


According to documentation ( :

2.7 Proxy Configuration

This feature is only available when you have configured web service calls to use the (optimized) implementation in the project’s runtime settings.

In 7.23.9 this option is available under Runtime:

However in 8.5.0 I do not have a configuration option "Web Service Calls” as mentioned in

3.13 Web Service Calls

The way web services are called has been optimized, which means you can use custom proxy settings for each web service call. However, this implementation does not support complex schemas that use a policy reference with an algorithm suite. This configuration option allows you to use the old implementation, in case you need this feature.