On-premise MxAdmin without roles

Hi all, For an on-premise application, from one deployment to another we changed the full project roles structure, deleting ALL roles and created new project roles. Also the MxAdmin/Administrator assigned role in the 'Project Security' > 'Administrator' was deleted. I assigned the MxAdmin a new role. Since this new deployment I wanted to use the MxAdmin to assign all business users their new project roles, but.... I get a blank page. After quite some extensive debugging (deleting possibly conflicting widgets, changing homepage settings, checking security settings, opening page via Javascript in the browser console, ) I get the feeling that someway the Mendix client is now corrupted because the old MxAdmin role doesn't exist anymore. I also tried updating the MxAdmin user with the new userrole in the database via an update query in the Microsoft SQL database, but still no luck. Note that locally everything is working fine in all browsers with my PostGres database. The only way I think we can go now is deleting the database and recreating it again. Does anybody have any other ideas?
1 answers

Have you checked the userrole table? You should have a record for MxAdmin and the new Administrator role (two ids's).

You can create users and copy the password hashes in the database with a sql script.

Can you create the MxAdmin user with the Mendix Server console?


Edit 1: if you have no MxAdmin record in the database the Update Password function will create one.