Error: Out of memory: Increase max_locks_per_transaction

Hi all,  I am currently importing data using database replication. I'm importing roughly 7000 records. And I get this error: This is in the Test environment, it works fine locally.  I've done some searching for max_locks_per_transaction and it's a postgres setting. Many thanks,  Garion
1 answers

Hello Garion,

While I can't see a way to edit max_locks_per_transaction within an environment, you can change the maximum number of db connections.

You'll find details on how to do it here, at the bottom of the page:

Hope this helps