Mysql 8.X error when using as custom database

I’m trying to use my own database as main db for mendix, I’m getting this following message :  Opening JDBC connection to Some( failed with SQLState: 28000 Error code: 1045 Message: Access denied for user 'root'@'' (using password: NO) Retrying...(2/4) This is the configuration: IMPORTANT: Mysql 5.7 works with same settings but not when using version 8.X Mysql version : mysql  Ver 8.0.15 for Linux on x86_64 (MySQL Community Server - GPL)
2 answers

This could be a number of issues: user may not have ability proper CRUD permissions, the database is not configured to allow access from the IP address you’re trying to connect from, database information is not entered correctly, the server might not be running (if a local db).

This worked for me once or twice. Try going over to the Custom tab in the Configuration window and entering the database information there. Here’s what you’ll need:


SourceDatabaseHost | [YOUR HOST]
SourceDatabaseName | [YOUR DB NAME]
SourceDatabaseUserName | [YOUR USERNAME]
SourceDatabasePassword | [YOUR PASSWORD]


This has worked with MySQL and PostgreSQL. You just have to make sure the database is empty. Mendix will synchronize your projects domain model with the database you are connecting too.

Reference Link:


Try this:

use mysql;

alter user 'root'@'localhost' identified with mysql_native_password by '********';

flush privileges;