Deploying a web custom font

Hi, I’m hoping someone can help with this. We’ve succesfully added a couple of custom fonts to our project which work fine on everyone's dev version but once we create a package and push it into test the files don’t seem to be getting transported. It feels like I’ve missed a flag somewhere to tell it to take the font files (.eot, .woff.svg). Is there something I need to explicitly declare to get it to package up the files? I’ve tried putting them in the same folder as the glyphicons and in the resource folder but still no joy. Any help is greatly appreciated!   EDIT: A snippet from the package build process and the browser console on the test site:
3 answers

Hi Adam,
Make sure to use lower-case name for the font file. I can see the font at
but not at


Hope this helps


- Check if you have committed the files to the Team server. Otherwise, make sure to explicitly add the file and commit it.

- Check if you have added the fonts to the actual folder structure instead of deployment folder

- For regular fonts, add it to resources folder and make sure to add the font to the fop.xconf file


I had a similar issue. Locally the glyphicons displayed fine, but when deployed on our Windows servers, they were missing everywhere in the app.

On Windows, the deployed app is fronted by IIS, and I added a MIME type font/woff2 for the file extension .woff2 in the MIME Types IIS configuration for the IIS website. This fixed the problem for us. I hope this helps.