Mendix On-Premises Deployment

Hello Team, I have been presented with a task to deploy mendix on-premises(windows machine) using mendix-service-console and IIS. There are totally 3 servers 1) Database server 2) Application server 3) Web-server. Previously I have deployed a Mendix app and its running perfectly using Just 2  server set-up DB & App-server, following this doc- Steps Followed where, 1)Installed & run Mendix-service-console, reverse proxied it through IIS following all the Rewrite & ARR etc rules mentioned in the above doc. 2)Synchronized the database of the running application in mendix-server-console, with the Db-server endpoints.   Now Since I'm presented with an Extra server(web-server), I'm unable to deploy the Mendix-app this time around.  What I have done is: A) Installed & Run Mendix-service console in Application-server. B)Synchronized the database of the running application in mendix-server-console, with the Db-server endpoints. C) Installed IIS in web servers, followed all the Rewrite & ARR rules mentioned in this –  and pointed to the build files(static content) transferred from the app-server to web-servers IIS and reverse proxied the application running in "StepA" to this. But even after following all these, the mendix-app is not running through my web server's IIS. Query, is there anything I'm missing, is the setup Im following right, should the web-server too need the mendix-service-console running in it to work? Thanking you for your valuable answers in Advance.
1 answers

My experience with configurating IIS is that might be a hassle. To figure out wat is running and what isn’t, my plan would be:


  • Is the Mendix App running on the Application Server? (on the Application Server, open a browser and goto the url your Mendix App is running, might be localhost:8080 by default). If not running, check your Mendix logfiles
  • When the Mendix App is running, then there might be a issue with IIS. This could be anything, check IIS the logfiles
  • Are you able to access the Mendix App from the Web-server? There could be a security setting. 


Hope this helps.