App does not show updated home page

Hi dear Mendix people I am coming back to Mendix after several years of not using it and am having trouble viewing a sample application (created in Studio Pro 9.1.0) based on the LearnNowTrainingManagement App. When I Publish and then View App with the Responsive Web profile, it shows an old home page rather than the one with my latest changes. I’ve tried clearing the cache in Chrome and refreshing the page. My Home Page seems to be visible to the correct user roles. It has worked a few times before but now insists in showing me an old version of the home page without the new menu items I have added. Also the Run Locally button never works – it seems to start the app but I don’t see the home page (in Chrome). localhost:8080 does not work.  The only way to run the App seems to be to Publish it and then to run it using F9. But still shows me an old version of the home page. For info, I am trying to import an Excel spreadsheet and have created menu items on the Home Page menu to the Excel Import Overview page and the MXObjects Overview page. But have failed to see them so far   Can anybody spot what I am doing wrong or what I should check? Thanks in anticipation Franco  
1 answers

Is there any other app using port 8080? You can try to set the port to 8081 (or any other) to see if the Run Locally button will work. Usually it's an app where you run an other mendix application on or using another program using any database.


But using publish and still viewing the old home page I cannot think of anything else but cookies or a wrong setup in your mendix.