Upgrading app - build failed: Cant find MX Version

I just upgraded an app from 7.23.8 to 8.18.13 and then to 9.7.0. I had to re-download and replace the DeepLink, Community Commons, Atlas UI, and SAML modules. I also had to export a few custom pages from the deeplink and atlas UI modules and re-imported. I ran the new project locally and everything looks good.   Once I committed it and attempted to create a package from the teamserver, it failed with the following line:   [teamserver-checkout] 2022-11-29T16:20:40.395482322Z Failed to determine MX version in /workspace/build/source/MyProject.mpr   Does anyone know if there’s a simple fix for this? 
2 answers


I got the same error earlier today after trying to Deploy to Licensed Cloud Node from Studio Pro.  For me, creating a package from Teamserver (in the cloud portal) worked.  Also, I was able to Create a Deployment Package in Studio Pro.  So I guess trying a couple of different things might get you past this.  If it keeps happening, I will file a ticket to get it resolved.


On a side note, its a weird error message.  Teamserver shows the Mendix version and of course Studio Pro knows the Mendix version.  Maybe a passing issue with the cloud portal.


Hope that helps, 



Hi Brian, hi all,


Follow-up: The Issue has been resolved from Mendix side. 


I have the same problem since a few days when trying to create a package from the cloud portal. I did not upgrade my app (my mendix version is 9.12.1), the error just appeared when trying to create a new package. 

Failed to determine MX version in /workspace/build/source 


When I create the package manually via Studio Pro (App → Create Deployment Package) and manually upload it to the cloud node, it works fine. 


Has there been an update to the cloud portal that could have this effect?