App Publishing not working

Hello, everyone. I have a free app that used to work until, well, yesterday. Today i’ve made some chages, committed them e tried to publish, as i’ve always done. The app is simply not publishing anymore. I’ve looked the log generated by the latest build output in the free apps and couldn’t see anything the would show me what’s wrong. The free url is not working anymore also. It just keeps on that screen of “ your app is waking up...” forever. I tried to export the app package, created a new app and imported the app package on this brand-new blank app and tried to publish it. Again, the deployment was not successful. Magically, for a short period of time, in this new app created, mendix was showing deployment failed, no environment selected but if you tried to access the free url it would show the start page. Bizarre!! but a couple minutes later it would return to the old page of free app waking up. I have no idea what is going on. I’ve read stuff here in the forum related to the problem, tried the solutions...nothing worked.   Below is what i’ve got in the latest build output everytime i tried to publish:   Pipeline created at 2023-05-10T02:49:53Z [teamserver-discovery] 2023-05-10T02:49:57.866118740Z Project: 8b8db589-9720-4cb7-b6fd-a5108c81131a [teamserver-discovery] 2023-05-10T02:49:57.866165036Z Determining repository type... [teamserver-discovery] 2023-05-10T02:49:58.621104250Z Found type: git [teamserver-discovery] 2023-05-10T02:49:58.621649826Z Found URL: [teamserver-checkout] 2023-05-10T02:50:11.778497220Z Project: 8b8db589-9720-4cb7-b6fd-a5108c81131a [teamserver-checkout] 2023-05-10T02:50:11.778500478Z Branch: main [teamserver-checkout] 2023-05-10T02:50:11.778502639Z Revision: 5df80850053d34ea46f2da69e9f55bf4dd5918ce [teamserver-checkout] 2023-05-10T02:50:11.778506845Z Getting temporary access URL... [teamserver-checkout] 2023-05-10T02:50:12.021651060Z Cloning repository... [teamserver-checkout] 2023-05-10T02:50:20.112350669Z Checked out revision 5df80850053d34ea46f2da69e9f55bf4dd5918ce [teamserver-checkout] 2023-05-10T02:50:20.876908574Z Finding MPR file... [teamserver-checkout] 2023-05-10T02:50:20.881473044Z Found: /workspace/build/source/CristalPet_Digital_Tracking_3.mpr [teamserver-checkout] 2023-05-10T02:50:20.882623241Z Mendix version: [compile] 2023-05-10T02:50:27.272817761Z [compile] 2023-05-10T02:50:27.272836776Z __ __ ____ _ _ _ [compile] 2023-05-10T02:50:27.272840801Z | \/ | | _ \ (_) | | | [compile] 2023-05-10T02:50:27.272843949Z | \ / |_ _| |_) |_ _ _| | __| | [compile] 2023-05-10T02:50:27.272846785Z | |\/| \ \/ / _ <| | | | | |/ _` | [compile] 2023-05-10T02:50:27.272850129Z | | | |> <| |_) | |_| | | | (_| | [compile] 2023-05-10T02:50:27.272853166Z |_| |_/_/\_\____/ \__,_|_|_|\__,_| [compile] 2023-05-10T02:50:27.272856256Z [compile] 2023-05-10T02:50:27.408742036Z v9.24.0.2965 [compile] 2023-05-10T02:50:27.408760370Z [compile] 2023-05-10T02:50:29.776755775Z Starting build for Mendix Project file: /workspace/build/source/CristalPet_Digital_Tracking_3.mpr [compile] 2023-05-10T02:50:29.777667811Z Using the following options: [compile] 2023-05-10T02:50:29.777709185Z * Build target: Package [compile] 2023-05-10T02:50:29.777717501Z * Deployment package file: /workspace/build/dist/4033f57a-2e42-4071-aa08-6e4c07784fd7.mda [compile] 2023-05-10T02:50:29.777720145Z * Model version: [compile] 2023-05-10T02:50:29.777722377Z * Model description: Automatically generated deployment package for Free App deployment. [compile] 2023-05-10T02:50:29.777725454Z Reading project file... [compile] 2023-05-10T02:50:32.285454452Z Building project... [compile] 2023-05-10T02:50:32.289552958Z Executing step 'Synchronize with file system' [compile] 2023-05-10T02:50:32.289742506Z * Synchronizing with file system... [compile] 2023-05-10T02:50:33.457148264Z Executing step 'Initialize' [compile] 2023-05-10T02:50:33.480538845Z * Preparing deployment... [compile] 2023-05-10T02:50:33.524123400Z Executing step 'Check prerequisites' [compile] 2023-05-10T02:50:33.524331876Z * Checking for errors... [compile] 2023-05-10T02:50:36.291045204Z Executing step 'Clean deployment directory' [compile] 2023-05-10T02:50:36.291070585Z * Cleaning data broker files... [compile] 2023-05-10T02:50:36.291318345Z * Cleaning deployment directory... [compile] 2023-05-10T02:50:44.158817272Z * Cleaning ml deployment directory... [compile] 2023-05-10T02:50:44.159115316Z * Cleaning web deployment directory... [compile] 2023-05-10T02:50:44.159248477Z * Cleaning source web deployment directory... [compile] 2023-05-10T02:50:44.159420017Z * Cleaning native deployment directory... [compile] 2023-05-10T02:50:44.159482663Z Executing step 'Perform model transformations' [compile] 2023-05-10T02:50:44.165012883Z * Applying model transformations... [compile] 2023-05-10T02:50:44.176370390Z Executing step 'Generate deployment files' [compile] 2023-05-10T02:50:44.177796755Z * Writing files... [compile] 2023-05-10T02:50:48.986029142Z Executing step 'Prepare deployment' [compile] 2023-05-10T02:50:48.987420562Z * Generating styles for icons [compile] 2023-05-10T02:50:48.989289232Z * Cleaning web deployment directory... [compile] 2023-05-10T02:50:49.153348558Z Executing step 'Build deployment structure' [compile] 2023-05-10T02:50:49.154567901Z * Generating data broker files... [compile] 2023-05-10T02:50:49.174121692Z * Exporting ml models to ml deployment directory... [compile] 2023-05-10T02:50:49.179123822Z * Compiling theme files... [compile] 2023-05-10T02:50:49.181840989Z * Exporting a theme... [compile] 2023-05-10T02:50:49.555208269Z * Generating font files for icons [compile] 2023-05-10T02:50:49.556033558Z * Exporting pages... [compile] 2023-05-10T02:50:50.921404811Z * Exporting metadata... [compile] 2023-05-10T02:50:50.922989216Z * Exporting microflows model... [compile] 2023-05-10T02:50:51.065619947Z * Exporting custom widgets... [compile] 2023-05-10T02:50:51.173107163Z * Bundling custom widgets... [compile] 2023-05-10T02:50:56.951521899Z * Exporting pluggable native widgets... [compile] 2023-05-10T02:50:57.000157411Z * Exporting native pages [compile] 2023-05-10T02:50:57.219330801Z Executing step 'Save model to deployment directory' [compile] 2023-05-10T02:50:57.219354646Z * Saving model to deployment directory... [compile] 2023-05-10T02:50:57.741999849Z Executing step 'Finalize deployment structure' [compile] 2023-05-10T02:50:57.743205001Z * Post-processing generation results... [compile] 2023-05-10T02:50:57.743705803Z Executing step 'Bundle application' [compile] 2023-05-10T02:50:57.747155413Z * Compiling Java... [compile] 2023-05-10T02:51:36.007036456Z * Compressing web resources... [compile] 2023-05-10T02:51:36.274843461Z Executing step 'Compress deployment package' [compile] 2023-05-10T02:51:36.277170182Z * Creating deployment package... [compile] 2023-05-10T02:51:43.016301502Z Executing step 'Clean up' [compile] 2023-05-10T02:51:43.016434332Z * Cleaning up... [compile] 2023-05-10T02:51:43.262843881Z BUILD SUCCEEDED [compile] 2023-05-10T02:51:43.284895033Z Build successful! [compile] 2023-05-10T02:51:43.284914786Z Results: [compile] 2023-05-10T02:51:43.285577475Z /workspace/build/dist/4033f57a-2e42-4071-aa08-6e4c07784fd7.mda [teamserver-tag] 2023-05-10T02:52:02.021087525Z Project: 8b8db589-9720-4cb7-b6fd-a5108c81131a [teamserver-tag] 2023-05-10T02:52:02.021090473Z Branch: main [teamserver-tag] 2023-05-10T02:52:02.021092441Z Revision: 5df80850053d34ea46f2da69e9f55bf4dd5918ce [teamserver-tag] 2023-05-10T02:52:02.021094408Z Tag name: [teamserver-tag] 2023-05-10T02:52:02.021096305Z Tag description: Automatically generated deployment package for Free App deployment. [teamserver-tag] 2023-05-10T02:52:02.269047548Z Tagging revision... [teamserver-tag] 2023-05-10T02:52:03.338680206Z All clear! [upload] 2023-05-10T02:52:25.241613921Z Uploading the package [upload] 2023-05-10T02:52:37.545334163Z Package is uploaded
1 answers

You better file a Mendix Support Ticket.


Meanwhile say you make a new app and locally pull the code, replace the contents of the old project into this new App and then try deploying. Does that solve?