Getting a error when trying to checkout the remote repository

1
Getting this error after I tried to delete an older version of my branch and re-pulling that from the server:    LibGit2Sharp.NameConflictException: 'D:/Mendix working documents/SURMgmtServices-develop_2' exists and is not an empty directory    at LibGit2Sharp.Core.Ensure.HandleError(Int32 result) in /_/LibGit2Sharp/Core/Ensure.cs:line 154    at LibGit2Sharp.Core.Proxy.git_clone(String url, String workdir, GitCloneOptions& opts) in /_/LibGit2Sharp/Core/Proxy.cs:line 278    at LibGit2Sharp.Repository.Clone(String sourceUrl, String workdirPath, CloneOptions options, ProxyOptions proxy) in /_/LibGit2Sharp/Repository.cs:line 854    at Mendix.Modeler.VersionControl.Actions.Git.Requests.Clone.GitCloneLibGitRequest.ExecuteRequest() in Mendix.Modeler.VersionControl\Actions\Git\Requests\Clone\GitCloneLibGitRequest.cs:line 50   Would appreciate if there is a way to troubleshoot this issue.    Thanks  Josiah
asked
3 answers
1

Hi Josiah,

 

I would suggest to move the current directory (D:/Mendix working documents/SURMgmtServices-develop_2) in another folder & then  try to re pulling branch from the server.

 

Hope  it works.

 

 

answered
0

Thanks for the suggestion.

 

Managed to find an alternative method of pulling the branch using and earlier version of mendix than using the updated version to read the branch directly. 

 

I’ll try the other suggestion next time I see it. Thanks

answered
0

Hi,

I got it resolved by changing the folder location. I had a longer file path with multiple nested folders which caused the issue. The maximum character allowed for file path is 260.  I changed it to simple filepath like C:/Mendix/Myapp which worked. 

Hope this alternate solution would help someone.

 

answered