Bad experience with Docker Mendix Buildpack latest version

Hi Folks, I’ve tried to evaluate Docker Mendix Buildpack latest version by following the instructions, but so far without any luck,   Those are the steps i’m following: git clone --branch v5.0.2 --config core.autocrlf=false cd docker-mendix-buildpack tests/   Resulting in: => [internal] load build definition from Dockerfile                                                                                                                  0.0s  => => transferring dockerfile: 3.48kB                                                                                                                                0.0s  => [internal] load .dockerignore                                                                                                                                     0.0s  => => transferring context: 2B                                                                                                                                       0.0s  => CANCELED [internal] load metadata for                                                                                         1.2s  => ERROR [internal] load metadata for                                                                                        1.2s ------  > [internal] load metadata for ------ Dockerfile:10 --------------------    8 |         9 |     # Build stage   10 | >>> FROM ${BUILDER_ROOTFS_IMAGE} AS builder   11 |        12 |     # Build-time variables -------------------- ERROR: failed to solve: mendix-rootfs:builder: pull access denied, repository does not exist or may require authorization: server message: insufficient_scope: authorization failed   I’ve tried it on multiple machines ( Ubuntu, macos…. ) I would like to eventually build and push a docker image with my app.   Thanks a lot. Kfir 
2 answers

I ran into similar issues when following the instructions.
For me, it solved the problems by first creating the builder images locally.


From within the buildpack folder, execute:

docker build -t mendix-rootfs:app -f rootfs-app.dockerfile .

docker build -t mendix-rootfs:builder -f rootfs-builder.dockerfile .

You can then build your app via:
docker build --tag fancydockeruser/fancymendixapp:latest .


The above only works if you have your deployment package extracted to the projects folder within the buildpack. If the location is different, you'll have to used the --build-arg BUILD_PATH="./{project folder}" with the command above.


Good luck!







Have a look at: 

Try adding --platform=linux/amd64 into the two “FROM” build stage that you have inside the Dockerfile.

It should look like this:



# Build stage
FROM --platform=linux/amd64 ${BUILDER_ROOTFS_IMAGE} AS builder



FROM --platform=linux/amd64 ${ROOTFS_IMAGE}


Let me know if it’s working out for you….