No data when publishing

Hey, I have just published my app using the free version of mendix pro and all the data is missing in the published version. As far as I know when publishing for the first time the current data snapshot is published as well. At least that's how it has been with my last apps. This time however there is no data at all. I've tried unlinking and republishing, doing the same after pushing a new data snapshot and also tried the whole thing after importing everything to a new team server. The issue remains.   Another odd thing: after publishing the admin login is not working and my app tells me that the username or password is incorrect.   Thank you for your help! Mendix Version 10.6.3
1 answers

Hi Luca, I ran into this problem as well and found the answer in another discussion - They basically explained that once a mendix app is published, then all data created locally is erased.


However, you can still use the 'demo_administrator' and 'demo_user' demo user credentials to sign in to your published app: Go to app settings > Security > Demo users > Select one of the demo users and select 'copy password to clipboard' to use as the demo user's password when signing in. Hope that helps! 


Screenshot (2620).png