Cant re/start application in environment since after start up microflow not working as expect

Hiii everyone, I've been having problems today to start/restart my application. I started using the Mendix SSO Module, it was working absolutely fine until I tried deploying it. I can create a package and I'm able to deploy it but I can't start the app, it says that it had a problem restarting and should check the logs for the error.    I went to the logs and this is what it says.   I checked my configuration and it's this way.   From what I understand, according to the logs I'm missing that email address since it's expected and I'm not providing it but I don't know where I can provide it since this is the after start up microflow, also my login page is not an actual page in Mendix because I'm using a company theme and it's a html login page. I also checked the html file and there's just one usage for Email, should I change it there? Instead of email use username or whatever my attribute is?   If I deactivate the AfterStartUp microflow, app can be restarted an used but after some minutes, like 10-15, a red cross appears in the environment.    I don't really know how to solve this, I'm running out of possible solutions :( I read a lot of answers to similar questions to this one in the forum but none of them worked/applied for me.    I used almost everything as it was in the Mendix SSO Module, I created my own named CustomMendixSSO and just changed to the users entity I'm using to create and store users instead of using the default one but apart from that everything is the same.    Thanks in advanced!! 
0 answers