Could not find part of the path

Hello, I am wanting to create a Mendix Application, but when I deploy I get this error below. I have tried undoing all of my previous changes and back tracing yet I still get it. Could not find a part of the path [...]\Documents\Mendix\ISU_Prototype-main_2\deployment\web\widgets\MobileFeatures'. Is this something I can fix or do I have to reinstall Mendix? I am not quite sure how to debug this.
3 answers

Hi Mark!

Have you renamed your project folder (ISU_Prototype-main to ISU_Prototype-main_2 perhaps)?
If so, revert the name, run it again.

And have you tried cleaning your deployment directory (Menu in Modeler -> Project -> Clean Deployment Directory)?
If not yet, this will solve a lot of your problems usually.

Kind regards,


You solved it. I just deleted everything like you said it went well when I downloaded everything again. I am still super new to a lot of this, but you saved the day. I was setting up a demo for a coworker. Thanks!!!



After I made some changes to my (running) project, there was an error while deploying like Could not find part of the path ….\widget ….

After cleaning the deployment directory another error occurs: Could not find part of the path ….\model\dependencies.json

What is the problem here, and where did it come from? And of course, how to solve this?

Thanks in advance