How to solve the question The app is already being deployed.

I have encountered a problem when I try to run the project, simply say "The app is already being deployed. Please wait for the current deployment to finish before attempting a new one." If I tried to run locally, it shows and operates normally. Anyone know how to fix that?    PS. If I directly press view, there will be a page shown in the browser, but it is not the latest version.
2 answers

Hi Haoyu,

It sounds like you clicked "run" before the sandbox environment was done deploying. If you wait a minute or two and press run again, it should redeploy with the current changes. If after awhile it still doesn't let you deploy again, you can check your application logs in the sprinter portal under the environments tab to see if there are any errors.

"Run" will deploy your application to your free application sandbox in the cloud. "Run locally" will deploy your app locally on your computer so you can test.


And sometimes the above will still not work. You then have to file a support ticket.