I encountered a problem with Web Modeler 2.0.340 which stopped publishing.

Hi, I finally overcame the problem and want to share the issue in hope that somebody can use the workaround when will be in a similar trouble. In short: Web Modeler stopped publishing after creation of associations. I fixed it only by recreating the associations in Desktop Modeler.   The whole story is below. Versions: Web Modeler 2.0.340 on Mendix I created an app in Web Modeler, added pages, entities. The app was successfully published and run in free Mendix cloud. Then I created a few associations, added some microflow and it stopped publishing. The diagnostics was very poor, no specific errors, so I could not find a cause. Some strange messages like: 502 Bad Gateway Nginx or simply publishing failed. Tried to load the app into Desktop Modeler 7.23, but even then the app could not be deployed from the Desktop Modeler, both in the Mendix cloud and locally.   The error message I found was: An error occurred while initializing the Runtime: null -------- com.mendix.m2ee.api.AdminException: An error occurred while initializing the Runtime: null                 at com.mendix.basis.impl.MxRuntimeImpl.start(MxRuntimeImpl.java:368) Caused by: java.lang.NullPointerException: null                 at com.mendix.basis.objectmanagement.SchemeManagerImpl.initializeAssociations(SchemeManagerImpl.java:451)                 at com.mendix.basis.objectmanagement.SchemeManagerImpl.initialize(SchemeManagerImpl.java:192) ...   Looking at it I tried a workaround which worked: deleted existing associations (one by one, saved the project each time) and recreated them in Desktop Modeler.   Seems the Web Modeler had trouble when creating associations, but there were no diagnosticts to find it out.
0 answers