Error staging application: App staging failed in the buildpack compile phase problem

Hello, We are developing a Mendix app to push MindSphere OS. We have finished to develop first simple app but while trying to push the app via cloud foundry, we get an error as it is in the capture. We are not trying to push the app through a manifest file, which we tried and failed, but we are trying to write all the disk_quota, memory, instances, buildpack, health_check_timeout instances through cloudfoundry commands. Does anyone has an idea about this error? Thank you for your help beforehand.    
4 answers

The only error that it mentions, is that it failes compiling the Mendix buildpack.

Did you inspect the logs files of the app?

$ cf logs SiemensMindSphereStartersApplication_1.2.0.14.mda --recent

Maybe that will give you a hint, otherwise I suggest you add the applicaiton logs to your question.

Also I noticed that the buildpack argument is different from the one in my cheat sheet where I reference the full URL. The one I use is the following:


Actually the custom buildpacks are not allowed so when I tried to use -b command of CF I am getting the error of Custom Buildpacks are not allowed.

I tried to create also a buildpack which I downloaded from GitHub but I am not allowed to do so neither.

When I tried the app get app logs, I got nothing written. Maybe I am looking to wrong place..



This problem has been solved with using Manifest file to push the app. CF commands didn’t work but when I tried to push the app with manifest file BUT when the app will be pushed with manifest file, the root directory has to be changed to the folder where your .mda file is. Then only command which has to be used is cf push.



It is possible to have the CF manifest file in a different folder than your mda file.
As described here: 
you can add a “path: /path/to/your/mda” into your manifest.


use “cf push -p “/path/to/your/mda”